Mail.ruПочтаМой МирОдноклассникиВКонтактеИгрыЗнакомстваНовостиПоискОблакоComboВсе проекты

Задача для четвертого класса знатокам Excel

Андрей Кириллов Знаток (388), закрыт 13 лет назад
У Васи было 2 рубля, Петя принес еще 2 рубля. Вместе у них стало 4 рубля. Они купили пряник за 4 рубля. Вместе у них стало 0 рублей. И конечно если не "0 рублей" то мы посчитали "неверно".

Перенесем всю эту задачу в Excel:
Ячейка A1(было 2р.) - (цифра 2)
ячейка B1(добавили 2р.) - (цифра 2)
ячейка С1(стало сумма А1 и В1) - (формула =А1+В1)
ячейка D1(трата 4р.) - (цифра 4)
ячейка E1(итог верен или неверен) - (формула =ЕСЛИ(C1-D1<0;"неверно";C1-D1)

Наверно все понятно, что если они потратят 5 рублей, то это будет ошибка (в ячейке будет гореть "неверно").

Данная формула работает со всеми числами кроме одних:

ячейка С1(стало сумма А1 и В1) - (имеет итоговое значение 27,3)
ячейка D1(трата 27,3р.) - (цифра 27,3)
ячейка E1(итог верен или неверен) - (формула =ЕСЛИ(C1-D1<0;"неверно";C1-D1)
Формула выдает ошибку "неверно". И почему то только с этими числами.
Можете проверить сами на калькуляторе. А Excel считать ноль не хочет.
Вопрос - почему так и в чем проблема? Ведь на других числах формула работает.
Дополнен 13 лет назад
Поправка, попробуйте так:
А1 = 12,2
В1 = 15,1
в этом случае не работает точно!
Лучший ответ
Ludmila4000 Мудрец (12930) 13 лет назад
Не знаю, почему у тебя не работает. У меня работает с любыми цифрами. В описанном случае с 27,3 выдает 0, как и положено.
Попробуй повнимательне написать число 27,3 (возможно, у тебя точка вместо запятой) . Возможно, оно у тебя в текстовом формате записалось. Тогда надо изменить формат ячейки на числовую (правой кнопкой по ячейке, в меню "Формат ячейки" вкладка "Число").
Возможно, число на самом деле более длинное после запятой (например, 27,31), но отображается только десятичный знак. Это тоже можно проконтролировать и изменить в "Формате ячейки".
Остальные ответы
Dinoka Мастер (2077) 13 лет назад
Боже. . это что решение задачи.. . Теперь вместо Ответов будут решать задачки....: -))
Тимa Знаток (251) 13 лет назад
Все дело в алгоритмах
Андрей КирилловЗнаток (388) 13 лет назад
Поясните про алгоритмы
Поясните, какие слагаемые в Вашем случае дают 27,3. Я проверил, 10 + 17,3; 20 + 7,3; прямой ввод 27,3 в C1. Работает корректно. MS Excel 2003, SP3.
JoKa Fern Lowd Просветленный (22740) 13 лет назад
Всё в порядке с формулой, это глюки экселя.
A1= 12,1
B1= 15,2
C1= =A1+B1 даёт 27,3
D1= 27,3
E1= =ЕСЛИ (C1-D1 < 0;"неверно";C1-D1) даёт "неверно"
F1= =C1-D1 даёт 0
G1= =F1 < 0 даёт ЛОЖЬ
H1= =(C1 < D1) даёт ЛОЖЬ
I1= =(C1-D1 < 0) даёт ИСТИНА

Из рассмотрения результатов можно сделать вывод, что ошибка делается при вычислении выражения C1-D1 < 0.
Андрей КирилловЗнаток (388) 13 лет назад
Так в итоге это не только у нас?

последнии строчки не понял?
JoKa Fern Lowd Просветленный (22740) Уже подправил, просто ответы мэйл ру что-то косячит со знаками меньше, видимо за тэги принимает. E1= =ЕСЛИ(C1-D1 < 0;"неверно";C1-D1) даёт "неверно" F1= =C1-D1 даёт 0 G1= =F1 < 0 даёт ЛОЖЬ H1= =(C1 < D1) даёт ЛОЖЬ I1= =(C1-D1 < 0) даёт ИСТИНА
Похожие вопросы