Mail.ruПочтаМой МирОдноклассникиВКонтактеИгрыЗнакомстваНовостиКалендарьОблакоЗаметкиВсе проекты

Спектроанализатор SA6. Виснет наглухо после выключения.

Сергей Искусственный Интеллект (288495), на голосовании 9 месяцев назад
принесли "посмотреть". Собран на микроконтроллере STM32F405VGT6 .

Поведение такое: включаешь питание - появляются на плате вторичные напряжения +5в (на DSP надо полагать?) и +2,5в на микроконтроллер. Происходит успешная загрузка, прибор работает.
Выключаем прибор с кнопки - устройство завершает работу, выключается, вторичные напряжения питания пропадают.
Пытаемся еще раз включить - и хрен, появляются вторичные напряжения питания, прибор начинает жрать ток (350-400мА) , и прибор кирпич кирпичом, ни на что не реагирует, даже на длительное нажатие кнопки. Помогает только сбросить питание, отключить аккумулятор, подождать полной разрядки всех емкостей и МК, после чего , подав питание, все снова включается с кнопки как обычно.

Куда копать хоть приблизительно? Может такое поведение говорить о бракованном МК / прошивке МК , или 100% надо копать обвязку ? Питание в частности
Голосование за лучший ответ
Blockacc Anon Оракул (87054) 10 месяцев назад
мелкая логика мож не срабатывает?
Юрий Владимирович Просветленный (47056) 10 месяцев назад
Тут вряд-ли подскажут. Есть он на специализированных форумах ремонтников?
С таким дела не имел, а там при включении сброса не происходит? Даташит смотреть нужно.
СергейИскусственный Интеллект (288495) 10 месяцев назад
в микроконтроллерах я полнейший нуб, от того и спрашиваю. В основном балуюсь с бытовой электроникой. До МК и логики мозги так и не доросли, забивать начал потихоньку на это дело
Профессор Лебединский Оракул (87837) 10 месяцев назад
Возможно проблема с ПО . Надо начать с шитья .
Похожие вопросы