Mail.RuПочтаМой МирОдноклассникиИгрыЗнакомстваНовостиПоискВсе проекты

Двумерный массив mхn содержит некоторые буквы английского алфавита, расположенные в произвольном порядке.

Ученик (227), на голосовании 1 месяц назад
Двумерный массив mхn содержит некоторые буквы английского алфавита, расположенные в произвольном порядке. Написать программу, проверяющую, можно ли из этих букв составить заданное слово. Каждая буква массива используется не более одного раза.
Дополнен 1 месяц назад
на С
Голосование за лучший ответ
Мы верим в тебя. Ты справишься.
Для Каждой буквы Из Слова
Массив (буква) = Массив (буква) + 1
КонецЦикла
Для i=1 по m Цикл
Для j=1 по n Цикл
Буква = Двумерный (i, j)
Массив (Буква) = Массив (Буква) - 1
КонецЦикла
КонецЦикла
МожноСоставить = Истина
Для Каждой буквы Из Массив
Если Массив (буква) > 0 Тогда
МожноСоставить = Ложь
ПрерватьЦикл;
КонецЕсли;
КонецЦикла
Сообщить ( МожноСоставить );
Комментарий удален
Похожие вопросы
Также спрашивают