Mail.ruПочтаМой МирОдноклассникиВКонтактеИгрыЗнакомстваНовостиКалендарьОблакоЗаметкиВсе проекты

Решение задачи по информатике Кто шарят за Кумир- сюда.

Gonor Ученик (100), закрыт 1 неделю назад
Те, кто шарят за Кумир!

На бесконечном поле есть горизонтальная и вертикальная стены.
Правый конец горизонтальной стены соединен с нижним концом вертикальной стены. Длины стен неизвестны. В каждой стене есть ровно один проход, точное место прохода и его ширина неизвестны. Робот находится в клетке, расположенной непосредственно над горизонтальной стеной у ее левого конца. На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные непосредственно выше горизонтальной стены и левее вертикальной стены. Проходы должны остаться незакрашенными. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведенного выше рисунка Робот должен закрасить следующие клетки (см. рис.).

При исполнении алгоритма Робот не должен разрушиться, выполнение алгоритма должно завершиться. Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для любого допустимого расположения стен и любого расположения и размера проходов внутри стен.
Лучший ответ
Владимир Втюрин Высший разум (104756) 1 месяц назад


нц пока не снизу свободно закрасить вправо кц
нц пока снизу свободно и сверху свободно вправо кц
нц пока справа свободно закрасить вправо кц
нц пока не справа свободно закрасить вверх кц
нц пока слева свободно и справа свободно вверх кц
нц пока не справа свободно закрасить вверх кц

GonorУченик (100) 1 месяц назад
Благодарю;)
Остальные ответы
Похожие вопросы