Mail.ruПочтаМой МирОдноклассникиВКонтактеИгрыЗнакомстваНовостиКалендарьОблакоЗаметкиВсе проекты

Помогите срочно сделать формулу в exel

Кирилл Щукин Ученик (116), открыт 2 недели назад
Нужна формула =Если ....... (во втором скриншоте пример значений)
3 ответа
Дивергент Высший разум (1680502) 2 недели назад
Используй вложенные функции "ЕСЛИ" и "И". Или не рубишь вообще?
Если твое количество в столбце, к примеру, Е, и начинается со строки 3, то в соседней ячейке:
=ЕСЛИ(E3=0;"Товара нет";ЕСЛИ(И(Е3>=1;Е3<=10);"Заказать";ЕСЛИ(И(Е3>=11;E3<=90);"Есть";"Срочно продать")))
И проследи, чтобы ВЕЗДЕ в "ЕЗ" буква Е или какая там у тебя будет была ЛАТИНСКОЙ, а не РУССКОЙ!
Только учти, что при использовании такой функции надо предусмотреть ограничения на ввод численных значений в столбце Е! Они должны быть целыми и не меньшими нуля! Иначе введешь в ЕЗ значение -2 - и получишь "Срочно продать"...
Проверил в Excel, всё работает.
Кирилл ЩукинУченик (116) 2 недели назад
Спасибо огромное!
Дивергент Высший разум (1680502) Да не за что... У меня в одном проекте этот =ЕСЛИ имел длину около 500 символов за ним...
DsD Мудрец (13484) 2 недели назад
как-то так
 =ПРОСМОТР(C3;{0;1;11;91};{"Товара нет";"Заказать";"Есть";"Срочно продать"}) 
ДивергентВысший разум (1680502) 2 недели назад
Конечно, но он почему-то просил с "=ЕСЛИ"...
Дивергент, "ЕСЛИ" и "Макрос" - это два слова, которые знают все новички. и при возможности показывают знание сленга Это не задание от педагога с обязательным использованием указанной функции. просто автор других функций не знает
Похожие вопросы